// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?:\S)(https?:[\S]*)(?:&ct=ga&cd=)").unwrap();
let string = "https://www.google.com/url?rct=j&sa=t&url=http://4pda.ru/forum/index.php?showtopic=701750&st=7440&ct=ga&cd=CAEYACoUMTQzMjUxOTE3ODExNDA5NDA0ODcyHGU3M2YyMjY3MmQ0NTY5MzU6cnU6ZW46UlU6Ukw&usg=AFQjCNGp1zcChJ_QT82U_lt_rWOuIkasBg";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}