use strict;
my $str = 'https://www.google.com/url?rct=j&sa=t&url=http://4pda.ru/forum/index.php?showtopic=701750&st=7440&ct=ga&cd=CAEYACoUMTQzMjUxOTE3ODExNDA5NDA0ODcyHGU3M2YyMjY3MmQ0NTY5MzU6cnU6ZW46UlU6Ukw&usg=AFQjCNGp1zcChJ_QT82U_lt_rWOuIkasBg';
my $regex = qr/(?:\S)(https?:[\S]*)(?:&ct=ga&cd=)/p;
if ( $str =~ /$regex/ ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}