package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^([+]?\d{1,2}[-\s]?|)[9|6|7][0-9]{8}$`)
var str = `+34962772244`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}