$re = '/^([+]?\d{1,2}[-\s]?|)[9|6|7][0-9]{8}$/';
$str = '+34962772244';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);