const regex = /^([+]?\d{1,2}[-\s]?|)[9|6|7][0-9]{8}$/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^([+]?\\d{1,2}[-\\s]?|)[9|6|7][0-9]{8}$', '')
const str = `+34962772244`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}