package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(19|20)\d\d[- \/.](0[1-9]|1[012])[- \/.](0[1-9]|[12][0-9]|3[01])$`)
var str = `1999-11-21
2019-01-31`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}