const regex = /^(19|20)\d\d[- \/.](0[1-9]|1[012])[- \/.](0[1-9]|[12][0-9]|3[01])$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(19|20)\\d\\d[- \\\/.](0[1-9]|1[012])[- \\\/.](0[1-9]|[12][0-9]|3[01])$', 'gm')
const str = `1999-11-21
2019-01-31`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}