package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\b(\w+)\s*=\s*(?:"([^"]*?)"|([^ ]*)\b)`)
var str = `a ="First Field" b=SecondField c3= "Third field value" delta = "" e_value = five!`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}