const regex = /\b(\w+)\s*=\s*(?:"([^"]*?)"|([^ ]*)\b)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\b(\\w+)\\s*=\\s*(?:"([^"]*?)"|([^ ]*)\\b)', 'g')
const str = `a ="First Field" b=SecondField c3= "Third field value" delta = "" e_value = five!`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}