$re = '/"((?:""|[^"])*)"/m';
$str = 'If cmd = "History Report" Then
Range("D2").Formula = "=TEXT(""" & createDate & """,""" & Replace(subtitleFormat, """", """""") & """)"
comment = "This task is completed!"
End If';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);