re = /"((?:""|[^"])*)"/m
str = 'If cmd = "History Report" Then
Range("D2").Formula = "=TEXT(""" & createDate & """,""" & Replace(subtitleFormat, """", """""") & """)"
comment = "This task is completed!"
End If'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end