re = /class=([^=]*)([^(a-z|A-Z|0-9|\-|_)])btn("|([^(a-z|A-Z|0-9|\-|_)]).*")/
str = ' <a href="tel:{{ message.contact_phone }}" data-message-phone-btn class="bottom-bar__btn"><i class="mypro-icon mypro-icon-phone"></i><br>{{ _("Appeler") }}</a>
<a href="sms:{{ message.contact_phone }}&body={{ body|urlencode }}" data-message-sms-btn class="bottom-bar__btn hide-for-medium-up"><i class="mypro-icon mypro-icon-sms"></i><br>{{ _("SMS") }}</a>
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end