import re
regex = re.compile(r"(^(?!foo\()|\)).*\"(.*)\"", flags=re.MULTILINE)
test_str = ("foo(\"some str1\"); // ignore\n"
"foo2(\"another string\"); // need this\n"
"\"simple string\"; // need this\n"
"foo(L\"wide str\"); // ignore\n"
"#define NAME \"name\" // need this\n"
"foo(\"1\") #define NAME \"name\" // need last one")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")