#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "([\.\w\?]+)\s+([\dABCDEF]+) - ([\dABCDEF]+)\s+([\dABCDEF]+)"
Local $sString = ".noinit 00001000 - 00001012 13 DATA (1 bytes space 00001013 - 00001013)" & @CRLF & _
".ramcode 00001014 - 000017CB 7B8 DATA " & @CRLF & _
".bss 000017CC - 00002A6A 129F DATA (1 bytes space 00002A6B - 00002A6B)" & @CRLF & _
".data 00002A6C - 00002B35 CA DATA " & @CRLF & _
"WARNING: Non-dotted segment name DSPSEGMENT2.DRIVER120" & @CRLF & _
"DSPSEGMENT2.DRIVER120 00002B36 - 00002B3D 8 DATA " & @CRLF & _
".ISOBUFFERS 00002B3E - 00002CBD 180 DATA " & @CRLF & _
".uart 00002CBE - 00002DBD 100 DATA (562 bytes space 00002DBE - 00002FEF)" & @CRLF & _
".qspidata 00002FF0 - 00002FFF 10 DATA " & @CRLF & _
".icache 00003000 - 00003FFF 1000 DATA (20480 bytes space 00004000 - 00008FFF)" & @CRLF & _
".rsstack0 00009000 - 000092FF 300 DATA " & @CRLF & _
".rsmails0 00009300 - 000096FF 400 DATA " & @CRLF & _
".trace 00009700 - 000098FF 200 DATA "
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")