# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"([\.\w\?]+)\s+([\dABCDEF]+) - ([\dABCDEF]+)\s+([\dABCDEF]+)"
test_str = (".noinit 00001000 - 00001012 13 DATA (1 bytes space 00001013 - 00001013)\n"
".ramcode 00001014 - 000017CB 7B8 DATA \n"
".bss 000017CC - 00002A6A 129F DATA (1 bytes space 00002A6B - 00002A6B)\n"
".data 00002A6C - 00002B35 CA DATA \n"
"WARNING: Non-dotted segment name DSPSEGMENT2.DRIVER120\n"
"DSPSEGMENT2.DRIVER120 00002B36 - 00002B3D 8 DATA \n"
".ISOBUFFERS 00002B3E - 00002CBD 180 DATA \n"
".uart 00002CBE - 00002DBD 100 DATA (562 bytes space 00002DBE - 00002FEF)\n"
".qspidata 00002FF0 - 00002FFF 10 DATA \n"
".icache 00003000 - 00003FFF 1000 DATA (20480 bytes space 00004000 - 00008FFF)\n"
".rsstack0 00009000 - 000092FF 300 DATA \n"
".rsmails0 00009300 - 000096FF 400 DATA \n"
".trace 00009700 - 000098FF 200 DATA ")
matches = re.search(regex, test_str)
if matches:
print ("Match was found at {start}-{end}: {match}".format(start = matches.start(), end = matches.end(), match = matches.group()))
for groupNum in range(0, len(matches.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = matches.start(groupNum), end = matches.end(groupNum), group = matches.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.