import Foundation
let pattern = #"([\.\w\?]+)\s+([\dABCDEF]+) - ([\dABCDEF]+)\s+([\dABCDEF]+)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
.noinit 00001000 - 00001012 13 DATA (1 bytes space 00001013 - 00001013)
.ramcode 00001014 - 000017CB 7B8 DATA
.bss 000017CC - 00002A6A 129F DATA (1 bytes space 00002A6B - 00002A6B)
.data 00002A6C - 00002B35 CA DATA
WARNING: Non-dotted segment name DSPSEGMENT2.DRIVER120
DSPSEGMENT2.DRIVER120 00002B36 - 00002B3D 8 DATA
.ISOBUFFERS 00002B3E - 00002CBD 180 DATA
.uart 00002CBE - 00002DBD 100 DATA (562 bytes space 00002DBE - 00002FEF)
.qspidata 00002FF0 - 00002FFF 10 DATA
.icache 00003000 - 00003FFF 1000 DATA (20480 bytes space 00004000 - 00008FFF)
.rsstack0 00009000 - 000092FF 300 DATA
.rsmails0 00009300 - 000096FF 400 DATA
.trace 00009700 - 000098FF 200 DATA
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}