using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(https?:\/{2}\w+\.\w+\/{1})";
string input = @"https://example.com/1234567890/
https://example.com/subdomain/subdomain2
https://example.com/domain
";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}