// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(https?:\/{2}\w+\.\w+\/{1})").unwrap();
let string = "https://example.com/1234567890/
https://example.com/subdomain/subdomain2
https://example.com/domain
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}