$re = '/(https?:\/{2}\w+\.\w+\/{1})/';
$str = 'https://example.com/1234567890/
https://example.com/subdomain/subdomain2
https://example.com/domain
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);