using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(.*?)\s*(\[[^\]]*\])";
string input = @"nemenin yang ngebet sangat ingin belanja [Mon Sep 22 13:46:19 ICT 2014]";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}