$re = '/(.*?)\s*(\[[^\]]*\])/m';
$str = 'nemenin yang ngebet sangat ingin belanja [Mon Sep 22 13:46:19 ICT 2014]';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);