re = /(.*?)\s*(\[[^\]]*\])/m
str = 'nemenin yang ngebet sangat ingin belanja [Mon Sep 22 13:46:19 ICT 2014]'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end