import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?!.*?(https?://)?([\\da-z.-]+)\\.([a-z.]{2,6})([/\\w .-]*)*/?).*$";
final String string = "http://www.google.com\n"
+ "afasfd adf sdf\n"
+ "sdfsdf sd\n"
+ "https://facebook.com";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}