re = /^(?!.*?(https?:\/\/)?([\da-z.-]+)\.([a-z.]{2,6})([\/\w .-]*)*\/?).*$/m
str = 'http://www.google.com
afasfd adf sdf
sdfsdf sd
https://facebook.com'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end