$re = '/^(?!.*?(https?://)?([\da-z.-]+)\.([a-z.]{2,6})([/\w .-]*)*/?).*$/m';
$str = 'http://www.google.com
afasfd adf sdf
sdfsdf sd
https://facebook.com';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);