const regex = new RegExp('\\bUSA\\s*-.*-\\s*\\b(search|display)\\b|\\b(search|display)\\s*-.*-\\s*USA', 'g')
const str = `USA - Apparel - search
USA - Shoes - search
USA - Accessories - search
USA - Apparel - display
USA - Shoes - display`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}