use strict;
my $str = 'USA - Apparel - search
USA - Shoes - search
USA - Accessories - search
USA - Apparel - display
USA - Shoes - display';
my $regex = qr/\bUSA\s*-.*-\s*\b(search|display)\b|\b(search|display)\s*-.*-\s*USA/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}