$re = '/\bUSA\s*-.*-\s*\b(search|display)\b|\b(search|display)\s*-.*-\s*USA/';
$str = 'USA - Apparel - search
USA - Shoes - search
USA - Accessories - search
USA - Apparel - display
USA - Shoes - display';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);