package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(20\d{2})(\d{2})(\d{2})`)
var str = `aaa_20150229_bbb
aaa_20120229_bbb
aaa_20000229_bbb
aaa_19000229_bbb
aaa_18000229_bbb
aaa_17000229_bbb
aaa_16000229_bbb
aaa_20150130_bbb
aaa_20150131_bbb
aaa_20150430_bbb
aaa_20150431_bbb`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}