$re = '/(20\d{2})(\d{2})(\d{2})/m';
$str = 'aaa_20150229_bbb
aaa_20120229_bbb
aaa_20000229_bbb
aaa_19000229_bbb
aaa_18000229_bbb
aaa_17000229_bbb
aaa_16000229_bbb
aaa_20150130_bbb
aaa_20150131_bbb
aaa_20150430_bbb
aaa_20150431_bbb';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);