// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"([a-zA-Z\:]){4,100}([a-zA-Z0-9]{8}[:-]([a-zA-Z0-9]{4}[:-]){3}[a-zA-Z0-9]{12})").unwrap();
let string = "urn:vcloud:user:2998042f-b91d-4c16-9de8-7feaf5e711a8
";
let substitution = "";
// result will be a String with the substituted value
let result = regex.replace(string, substitution);
println!("{}", result);
}