package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^(?:\s|\R)*(?:-----BEGIN NEW CERTIFICATE REQUEST-----)(?<request>(?:.*\R)+)(?:-----END NEW CERTIFICATE REQUEST-----)(?:\s|\R)*$`)
var str = `-----BEGIN NEW CERTIFICATE REQUEST-----
Lorem ipsum dolor sit amet, consectetur adipiscing elit, sed do eiusmod tempor incididunt ut labore et dolore magna aliqua. Ut enim ad minim veniam, quis nostrud exercitation ullamco laboris nisi ut aliquip ex ea commodo consequat. Duis aute irure dolor in reprehenderit in voluptate velit esse cillum dolore eu fugiat nulla pariatur. Excepteur sint occaecat cupidatat non proident, sunt in culpa qui officia deserunt mollit anim id est laborum.
*$ùù^$$*wc<:msdkfksq*ùf^pbqjkdgfnbpmsdto\\^@]^[#|@\^@^\]@~[|#\^~[{\`~
-----END NEW CERTIFICATE REQUEST-----
`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}