const regex = /^(?:\s|\R)*(?:-----BEGIN NEW CERTIFICATE REQUEST-----)(?<request>(?:.*\R)+)(?:-----END NEW CERTIFICATE REQUEST-----)(?:\s|\R)*$/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?:\\s|\\R)*(?:-----BEGIN NEW CERTIFICATE REQUEST-----)(?<request>(?:.*\\R)+)(?:-----END NEW CERTIFICATE REQUEST-----)(?:\\s|\\R)*$', '')
const str = `-----BEGIN NEW CERTIFICATE REQUEST-----
Lorem ipsum dolor sit amet, consectetur adipiscing elit, sed do eiusmod tempor incididunt ut labore et dolore magna aliqua. Ut enim ad minim veniam, quis nostrud exercitation ullamco laboris nisi ut aliquip ex ea commodo consequat. Duis aute irure dolor in reprehenderit in voluptate velit esse cillum dolore eu fugiat nulla pariatur. Excepteur sint occaecat cupidatat non proident, sunt in culpa qui officia deserunt mollit anim id est laborum.
*\$ùù^\$\$*wc<:msdkfksq*ùf^pbqjkdgfnbpmsdto\\\\^@]^[#|@\\^@^\\]@~[|#\\^~[{\`~
-----END NEW CERTIFICATE REQUEST-----
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}