import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:\\s|\\R)*(?:-----BEGIN NEW CERTIFICATE REQUEST-----)(?<request>(?:.*\\R)+)(?:-----END NEW CERTIFICATE REQUEST-----)(?:\\s|\\R)*$";
final String string = "-----BEGIN NEW CERTIFICATE REQUEST-----\n"
+ "Lorem ipsum dolor sit amet, consectetur adipiscing elit, sed do eiusmod tempor incididunt ut labore et dolore magna aliqua. Ut enim ad minim veniam, quis nostrud exercitation ullamco laboris nisi ut aliquip ex ea commodo consequat. Duis aute irure dolor in reprehenderit in voluptate velit esse cillum dolore eu fugiat nulla pariatur. Excepteur sint occaecat cupidatat non proident, sunt in culpa qui officia deserunt mollit anim id est laborum.\n\n"
+ "*$ùù^$$*wc<:msdkfksq*ùf^pbqjkdgfnbpmsdto\\\\^@]^[#|@\\^@^\\]@~[|#\\^~[{`~\n\n"
+ "-----END NEW CERTIFICATE REQUEST-----\n\n\n"
+ " \n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}