import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[\\s]{3,}\\d{1,}\\\\n";
final String string = "'\\ufeffTHE SONNETS\\n\\n 1\\n\\nFrom fairest creatures we desire increase,\\nThat thereby beauty’s rose might never die,\\nBut as the rip\n\n"
+ "1189\\nAnd yokes her silver doves; by whose swift aid\\nTheir mistress mounted through the empty skies,\\nIn her light chariot quickly is convey’d; 1192\\n Holding their course to Paphos, where their queen\\n Means to immure herself and not be seen.\\n'";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}