$re = '/[\s]{3,}\d{1,}\\\\n/m';
$str = '\'\\ufeffTHE SONNETS\\n\\n 1\\n\\nFrom fairest creatures we desire increase,\\nThat thereby beauty’s rose might never die,\\nBut as the rip
1189\\nAnd yokes her silver doves; by whose swift aid\\nTheir mistress mounted through the empty skies,\\nIn her light chariot quickly is convey’d; 1192\\n Holding their course to Paphos, where their queen\\n Means to immure herself and not be seen.\\n\'';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);