// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)[\s]{3,}\d{1,}\\n").unwrap();
let string = "'\\ufeffTHE SONNETS\\n\\n 1\\n\\nFrom fairest creatures we desire increase,\\nThat thereby beauty’s rose might never die,\\nBut as the rip
1189\\nAnd yokes her silver doves; by whose swift aid\\nTheir mistress mounted through the empty skies,\\nIn her light chariot quickly is convey’d; 1192\\n Holding their course to Paphos, where their queen\\n Means to immure herself and not be seen.\\n'";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}