package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[\w_.-]+@([\w-]+\.)+\w{2,4}$`)
var str = `(email@domain.com)
email@domain.com
(plainaddress)`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}