$re = '/^[\w_.-]+@([\w-]+\.)+\w{2,4}$/m';
$str = '(email@domain.com)
email@domain.com
(plainaddress)';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);