re = /^[\w_.-]+@([\w-]+\.)+\w{2,4}$/m
str = '(email@domain.com)
email@domain.com
(plainaddress)'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end