import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "([0-9]{4}-[0-9]{2}-[0-9]{2}\\s[0-2][0-9]:[0-5][0-9]:[0-5][0-9])\\.?[0-9]{0,3}";
final String string = "2015-04-04 12:48:53.962";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}