re = /([0-9]{4}-[0-9]{2}-[0-9]{2}\s[0-2][0-9]:[0-5][0-9]:[0-5][0-9])\.?[0-9]{0,3}/
str = '2015-04-04 12:48:53.962'
# Print the match result
str.match(re) do |match|
puts match.to_s
end