const regex = /([0-9]{4}-[0-9]{2}-[0-9]{2}\s[0-2][0-9]:[0-5][0-9]:[0-5][0-9])\.?[0-9]{0,3}/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('([0-9]{4}-[0-9]{2}-[0-9]{2}\\s[0-2][0-9]:[0-5][0-9]:[0-5][0-9])\\.?[0-9]{0,3}', '')
const str = `2015-04-04 12:48:53.962`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}