#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\<\"(?P<app_name>[^\"]+)\""
Local $sString = "{" & @CRLF & _
"<"app name1">: {" & @CRLF & _
""reason": "all ok"," & @CRLF & _
""upstreams": 1," & @CRLF & _
""dialouts": {" & @CRLF & _
""idle": 40," & @CRLF & _
""total": 40," & @CRLF & _
""connecting": 0" & @CRLF & _
"}," & @CRLF & _
"}, <"app name2": { "reason": "all ok", "upstreams": 2, "dialouts": { "idle": 15, "total": 15, "connecting": 0 }, }, <"app name3": { "reason": "all ok", "upstreams": 2, "dialouts": { "idle": 15, "total": 15, "connecting": 0 }, }, ..... }"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")