re = /\<\"(?P<app_name>[^\"]+)\"/m
str = '{
<"app name1">: {
"reason": "all ok",
"upstreams": 1,
"dialouts": {
"idle": 40,
"total": 40,
"connecting": 0
},
}, <"app name2": { "reason": "all ok", "upstreams": 2, "dialouts": { "idle": 15, "total": 15, "connecting": 0 }, }, <"app name3": { "reason": "all ok", "upstreams": 2, "dialouts": { "idle": 15, "total": 15, "connecting": 0 }, }, ..... }'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end