// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)\<\"(?P<app_name>[^\"]+)\""#).unwrap();
let string = "{
<\"app name1\">: {
\"reason\": \"all ok\",
\"upstreams\": 1,
\"dialouts\": {
\"idle\": 40,
\"total\": 40,
\"connecting\": 0
},
}, <\"app name2\": { \"reason\": \"all ok\", \"upstreams\": 2, \"dialouts\": { \"idle\": 15, \"total\": 15, \"connecting\": 0 }, }, <\"app name3\": { \"reason\": \"all ok\", \"upstreams\": 2, \"dialouts\": { \"idle\": 15, \"total\": 15, \"connecting\": 0 }, }, ..... }";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}