using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=<h2 class=""a-text-normal"">).*?(?=</h2>)";
string input = @"<h2 class=""a-text-normal"">The info to be matched</h2>
";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}