$re = '@(?<=<h2 class="a-text-normal">).*?(?=</h2>)@';
$str = '<h2 class="a-text-normal">The info to be matched</h2>
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);