re = /(?<=<h2 class="a-text-normal">).*?(?=<\/h2>)/
str = '<h2 class="a-text-normal">The info to be matched</h2>
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end