using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\b(?=[A-Z0-9]{7}\b)[A-Z0-9]+[0-9][A-Z0-9]*";
string input = @"I want this nr A7A3G1A but not this ANTENNA";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}